EvilLyrics forum

EvilLyrics => Bug reports => Topic started by: AVB100 on December 14, 2004, 05:46:32 AM



Title: Lyrics Posting
Post by: AVB100 on December 14, 2004, 05:46:32 AM
As I noted before the server mysteriously went offline and rolled everything back a week, not all of my lyrics are posting to the web site.

Problem #1: Ampersands (&) in the title/lyrics need to be encoded (%26) so they don't break the string

Problem #2: Many lyrics just don't post at all
Some lyrics files that do and don't work can be found here:
(Now offline)

Oh, and yes, I have a nice little script to process my lyrics.  I'm still working on it, adding features, etc, but I would be happy to share it with anyone that wanted it.

My personal lyrics page can be found here:
(Now offline)

Please let me know if you have any comments...

EDIT: Updated URL for my lyrics page
EDIT: Links offline


Title: Lyrics Posting
Post by: Marek on December 14, 2004, 02:04:10 PM
yes ... server was hacked, we were able to restore only version from 6/12 ...

yes .. i checked sending and the problem was that it didn't encode characters while sending them, so when it contained some weird charactes it didn't post it ... it was fixed now, fix will be included in the next build. thanks for reporting.


Title: Lyrics Posting
Post by: AVB100 on December 15, 2004, 05:37:10 AM
Great, thanks
Sorry to hear the server was hacked


Title: Lyrics Posting
Post by: AVB100 on December 15, 2004, 05:47:47 AM
Oh yeah, between the backup and when the server went down, I uploaded about 70 karaoke files, which are still stored on my computer, but are no longer in the karaoke database.  They don't upload, (I assume because they already did once)  Any ideas?


Title: Lyrics Posting
Post by: derf1776 on December 18, 2004, 05:07:38 AM
I had the same problem, you just have to re-do the karaoke's again, sorta trick evil lyrics into uploading them.


Title: Lyrics Posting
Post by: quirk on December 18, 2004, 06:56:17 PM
have you tried updating your kareoke database?


Title: Lyrics Posting
Post by: AVB100 on December 18, 2004, 08:39:37 PM
The karaoke problem was solved...with a little help from Marek
But, no reloading the karaoke index didn't work...